Versions

From Citizens Wiki
Jump to: navigation, search

This page contains information regarding current project versions of Citizens and some common related plugins.

Information About Version Handling

IT IS VERY STRONGLY RECOMMENDED THAT YOU ALWAYS RUN THE LATEST SERVER VERSION, AND LATEST PLUGIN JAR FILES.

Most projects are now multi-version, meaning latest versions of plugins support older Minecraft versions multiple back.

For all back-supported Minecraft versions, the latest Minecraft patch-version is preferred. So, for Minecraft 1.18, the specific server version to use is 1.18.2, as that is the latest patch-version of Minecraft 1.18.


Multi-supported Minecraft latest sub-versions:

- 1.8.8 - If you use 1.8 see this page for relevant information: Minecraft 1.8 Servers

- 1.9.4, 1.10.2, 1.11.2, 1.13.2, 1.14.4 - These versions are quite outdated and not fully supported by our projects.

- 1.12.2, 1.15.2 - This version is very outdated but still has some support.

- 1.16.5, 1.17.1, 1.18.2 - This is a newer version and is fully supported by our projects.

This list last updated March 8th, 2022.

Current Versions

Latest Citizens builds (All RECENT minecraft versions and some older versions) are always available here[1]

Latest Sentinel builds (All Minecraft versions that work with latest Citizens) are always available here[2]

Latest Denizen builds (All RECENT Minecraft versions) are always available here[3]

Latest Depenizen builds (All Minecraft versions that work with latest Denizen) are always available here[4]

Historical Versions Listing

The below lists contain versions of projects from before multi-version compatibility was in use, including for versions as far back as Minecraft 1.7.2.

Historical Citizens Versions

Warning: These are all unsupportable.

- 1420 1.10 [5]

- 1371 1.9.4 [6]

- 1362 1.9 and 1.9.2 [7]

- 1308 1.8.6 through 1.8.8 [8]

- 1230 1.8.3[9]

- BukkitDev 1.8[10]

- 1186 1.8 Protocol Hack[11]

- 1166 1.7.10[12]

- 1142 1.7.9[13]

- 1114 1.7.5[14]

- 1098 1.7.2[15]

- Cauldron 1.7.2 (Not officially supported): https://www.dropbox.com/s/mcm7g1gmyb6f820/citizens-2.0.11-1.7.2-Cauldron-B1.jar

- Cauldron 1.7.10 (Not officially supported): https://www.dropbox.com/s/sn4451lffuvr8o0/citizens-2.0.13-1.7.10-Cauldron-B2.jar

1.6.4 2.0.10 1021

1.6.2 after 2812 2.0.9 977

1.6.2 before 2812 2.0.9 890

1.6.1 2.0.9 881

1.5.2 2.0.8 817

1.5.1 2.0.8 799

1.5.0 2.0.8 778

1.4.7 builds 2607-2644 2.0.7 763

1.4.7 builds 2601 - 2607 2.0.7 667

1.4.6 2.0.6 662

1.4.5 2.0.5 639

Historical Denizen Versions

Warning: These are all unsupportable.

If you use Spigot 1.14.4 or 1.15.2, the latest release that supports these versions is here: [16]

If you use Spigot 1.13.2, the latest release that supports that version is here: [17]

If you use Spigot 1.12.2, the latest release that supports that version is here: [18]

If you use Spigot 1.8.8, 1.9.4, 1.10.2, or 1.11.2, the last release that supports these versions is here: [19]

1617 1.9.4[20]

1616 1.9 and 1.9.2[21]

1610 1.8.8[22]

1575 1.8.3[23]

1544 1.7.10[24]

1483 1.7.9[25]

1467 1.7.5[26]

1460 1.7.2[27]

- For evener older servers, [28] <- 'versionless' 0.9.6 jar. Not officially supported.

Historical Depenizen Versions

Warning: These are all unsupportable.

Build #227 for MC 1.7.10

Build #191 for MC 1.7.9

Build #189 for MC 1.7.5

Build #187 for MC 1.7.2

Historical Sentinel Versions

69 1.10[29]

40 1.9.4[30]

36 1.9 and 1.9.2[31]

Use latest dev builds!

Historical Sentry Versions

WARNING: SENTRY IS OUTDATED. USE SENTINEL INSTEAD.

Latest Sentry builds are always available here[32]

Previous version list Available here